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Tutorial 1: Finding and Displaying TRI Spatial Data Using Quantum GIS 
 
This tutorial will introduce you to the following: 
 

 Websites where you may search for TRI Data 

 Identifying spatial data, usable in a GIS 

 How to download and unzip shapefiles 

 Adding data to Quantum GIS 

 Adding basemaps to Quantum GIS 

 Working with Map Elements in the Print Composer 

 Saving and exporting your map 

Part 1.  Browsing for Geospatial Information 
 
Geospatial data are becoming ubiquitous.  There are many free and good quality data sources that you can begin studying to 
find spatial data for analysis.  The EPA’s Toxic Release Inventory is no exception.  From mobiles sites, to web-based queries, to 
stand-alone software, TRI data may be identified and extracted from several different sources. 
 

Types of Query Systems and Web Access to Toxic Release Inventory (TRI) Data 
 
Mobile Tools:  
 myRTK - http://myrtk.epa.gov/info/  
 
Web Browser Mapping Access:  
 TOXMAP - http://toxmap.nlm.nih.gov  
 
Web Browser Query Systems:  
 Envirofacts - http://www.epa.gov/envirofw/  
 TRI Explorer  
 P2 Search Tool   
 
Downloadable Software:  
 TRI.NET  
 RSEI  
 TRI-CHIP  
 
Raw Data Downloads:  
 Basic Data Files  
 Basic Data Plus Files  

 
The list above, though helpful, is not an exhaustive list.  Many other EPA databases, web query tools, and downloadable 
software packages allow users access to TRI data in conjunction with other datasets.  These particular links focus on TRI data 
as the main dataset. 
   
myRTK is the new mobile software that allows users to query TRI sites and study information about the facilities and TRI 
chemical releases on web-enabled cell phones or tablets.  TOXMAP, housed by the National Library of Medicine, allows users 
to query a map-based website to learn more about TRI releases and changes in the releases.  Envirofacts is the main web-
based query tool that enables users to query and download TRI data, based on a series of criteria (e.g. year of release, location 
of releases, type of industry, etc.).  Related to Envirofacts, TRI Explorer and the P2 Search tool allow users to examine TRI 
releases, as well as industry approaches for reducing hazardous chemical emissions.   
 
TRI.NET, RSEI, and TRI-CHIP allow you to download, install, and run software on your computer that gives you substantial 
flexibility in setting up TRI-based queries and data exports.  RSEI, for Risk Screening Environmental Indicators, generates a 

http://epa.gov/developer/myrtk.html
http://myrtk.epa.gov/info/
http://toxmap.nlm.nih.gov/
http://toxmap.nlm.nih.gov/
http://www.epa.gov/envirofw/
http://www.epa.gov/envirofw/
http://iaspub.epa.gov/triexplorer/tri_release.chemical
http://www.epa.gov/enviro/facts/tri/p2.html
http://www2.epa.gov/toxics-release-inventory-tri-program/download-trinet
http://www.epa.gov/opptintr/rsei/pubs/get_rsei.html
http://www2.epa.gov/toxics-release-inventory-tri-program/tri-chip-download-page
http://www2.epa.gov/toxics-release-inventory-tri-program/tri-basic-data-files-calendar-years-1987-2011
http://www2.epa.gov/toxics-release-inventory-tri-program/tri-basic-plus-data-files-calendar-years-1987-2011
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measure to compare TRI chemical releases and the potential impact of the releases on human health.  TRI-CHIP links TRI data 
with several additional datasets to help users understand the thresholds and limits of TRI chemical releases on health 
outcomes.  Last, the basic data files and basic data plus files contain the full, unfiltered TRI datasets, since the program began. 
Data are downloadable by year. 
 
For mapping, TRI data are also available in formats viewable through a variety of mapping software, such as ArcGIS and 
Google Earth.  Almost all TRI websites and software listed above also have a mapping component, where you can view the 
specific locations of TRI releases. 
 
 

Part 2.  Identifying Spatial Data 
 
Which of the above data sources have spatial data that can be used in a GIS?  The answer is all of them.  Any dataset created 
with addresses or geocodes (such as city, state, or latitude and longitude) can be mapped in a GIS.  However, converting data 
from tables or aspatial databases into a mappable GIS format often takes a few steps, which will be discussed in subsequent 
tutorials.  A good place to start, when first working with GIS, is with spatial data that is ready for GIS analysis.  Vector data 
layers are a common GIS data type that stores geometries, or points, lines, and polygons (think cities, roads, and country 
boundaries) that are spatially referenced (drawn on a spatial coordinate system, like the x and y of longitude and latitude).  
Vector data are available directly from Envirofacts (http://www.epa.gov/enviro/geo_data.html) and TOXMAP 
(http://toxmap.nlm.nih.gov/toxmap/facilities/download.do).  The data accessible from Envirofacts include the entire EPA 
facility registry system (FRS), or all the facilities regulated by several EPA programs.  The TOXMAP data include only TRI 
regulated facilities, so this tutorial begins with this site.  Open a web browser and navigate to the TOXMAP Downloads site 
listed above. 
 
Part 3.  Downloading and Unzipping Shapefiles 
 
You have some choices for downloading TRI data from TOXMAP.  You can use the web application to select up to 500 search 
results.  Or, you can download all the facilities and release data, or an ESRI shapefile of TRI Facilities.  Click to download both 
the facilities data and the ESRI shapefile for the entire TOXMAP TRI data set.  A shapefile is a common spatial data file type that 
is basically ready to go, once you open it in your GIS software (ArcGIS or QGIS).  Make sure that you are saving the file in a 
location where you can remember.  The default location for many web browsers is the Downloads folder.  You can also right-
click the links, and select “save link as..,” to navigate to a particular location on your computer where you would like to save 
your file.  In the Save As box, you can choose to store data in your Documents folder for example (if you’re using a Windows 
computer).  In this dialog box, you can also click the New Folder button to create a new folder in your Documents to save your 
GIS files.  However you manage your data, note that you will need to find these saved files again later. 
 

Shapefiles are geographic data that are in vector format.  Again, they can include basic geometric elements: points, lines, and 
polygons.  All shapefiles are bundled with at least two other file types: .dbf and .shx.  The database (.dbf) file contains records 
and information on each piece of geographic data stored in the shapefile.  For example, if the shapefile contains points, 
geographically referenced, then the database file will contain information about those points, such as the name of the city, 
maybe the city population, or in the case of the TRI data, the points contain information about each facility, its address, the 
name of the facility, and so on.  The other file is called a .shx file.  This file indexes the shapefile with the database file. 
 
After you have downloaded the shapefile (called “shapefile”) and the facilities data (called “facilities), you will need to unzip or 
extract them.  Looking in Windows Explorer, or with your web browser’s downloaded files menu, find the files that you 
downloaded.  Right-click shapefile and select to extract it, or “extract all.”  Once you’ve extracted it, you will see that the one 
file you downloaded, actually contains multiple files, some of which were discussed above (see an image of the extracted 
shapefile below).  Once you’ve extract the shapefile folder, also extract the facilities folder. 
 

http://www.epa.gov/enviro/geo_data.html
http://toxmap.nlm.nih.gov/toxmap/facilities/download.do
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Now you are ready to look at your data on a map. 
 
Part 4.  Adding Data to Quantum GIS 
 
If you haven’t already, make sure that Quantum GIS is installed on your computer (visit qgis.org to download the software).  
Navigate to the program and open it.  The left side of the screen contains an area called layers, where your data layers will be 
listed.  The right-side of the screen contains the map view, where you can visualize the spatial data.  Above and below are 
various menus and commands for viewing and analyzing spatial data.  To add the TOXMAP shapefile that you downloaded, 
select Layer (from the top menu) > Add vector layer … (you will notice that a button to the left does the same thing). 
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In the vector layer box, click Browse, and navigate to where you saved the TOXMAP shapefile, previously downloaded.  The file that 

you want to add is in the “shapefile” folder and it’s called facilities_all.shp, which is a SHP file (not the XML file, though the name is 

the same).  The source should look something like this: 

 

 

 

The map should initially look like the image below.  These are all the TRI regulated facilities contained on the TOXMAP 
website. 

 
 
Part 5.  Adding a Basemap to Quantum GIS 
 
A basemap helps provide a context to the point, line, and polygon layers that you might add to your map.  The basemap may be 
a satellite image of earth’s surface, or a road map, for reference.  For this example, since vector layers were introduced last, the 
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following steps introduce raster data.  Raster data is the other common spatial data type.  Unlike the geometry of the vector 
data, raster data contain grids of data.  Like the common storage method for digital photography, raster data contain rows and 
columns of individual grid cells or pixels.  One numerical value is stored in each pixel.  The data may be a visual metric, such as 
the color of the grid cell, or it may be another type of measurement, such as the estimated temperature or elevation of the grid 
cell area.  A wonderful resource for gridded data is NASA’s Earth Observation website: http://neo.sci.gsfc.nasa.gov/.  Navigate 
to this website and select the top link to “Land” data.  Scroll down and find the link to “Blue Marble: Next Generation” data, 
click on the link.  In the Downloads menu, change the File Type to GeoTIFF, and right-click on 0.1 degrees, 3600 x 1000 to save 
the link to an appropriate location on your computer. 

 
 
 
Back in Quantum GIS, start a new project by selecting Project > New (discard the map with the TRI data points).  Before you 
add data to this project, save the project with an appropriate name (e.g. Tutorial 1) in an appropriate place (e.g. GIS_Tutorials 
folder, or wherever you have stored your data).  Now, to add a base map, select Layer > Add raster layer… and navigate to the 
location where your NASA Blue Marble GeoTIFF file is saved.  Your map view should now display the blue marble data.  Next, 
add the EPA TRI locations on top of the blue marble display.  As before, select Layer > Add vector layer … and choose the 
facilities_all.shp file. 
 
If you have worked with maps on the web before, a number of the tools to zoom and pan should be familiar to you. 

 
To zoom in to a particular region, click on the magnifying glass with the plus button, and with the mouse, click and hold the 
mouse button just to the northwest of Washington state, and drag a rectangle to extend to the southeast corner of Florida, so 
that even Maine is included in the rectangle.  When you release the mouse, the map will zoom into the area of the rectangle 
that you drew. 
 

http://neo.sci.gsfc.nasa.gov/
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Now that you have 1) a vector layer (shape file), and 2) a raster layer (an image file), you may begin editing the layout and map 

elements of your map. 

 

Part 5.  Working with Map Elements in the Layout View 

 

Before you begin, save your project again (Project > Save).  To begin editing your map in the print composer, select Project > New 

Print Composer.  Create a title, such as “EPA Toxic Release Inventory (TRI) Sites,” and click OK.  A new window with an empty 

view opens.  In this view, you may prepare your map to be printed or exported.  To add your map to the view, select Layout, Add 

Map.  Click and hold the mouse from the upper left corner to the lower right corner, thereby drawing a rectangle that covers the page.  

When you release the mouse, your map should now appear on the page. 

 

By either selecting Layout > Add Label, or by clicking the Add Label button, click on the map, toward the top.  A tiny textbox that 

says QGIS appears.  On the right of the screen in Item Properties, you can edit the label.  Change the text to an appropriate title, such 

as “EPA Toxic Release Inventory (TRI) Locations” and change the font to an appropriate size.  You will need to manually resize the 

box that text is typed into, just drag a corner of the label box to expand the size of it. 

 

To add other map elements, select layout, then choose whatever elements you need: label, legend, arrow, or scale bar, for example.  

Add each of these to your map (select the map element, then click on where the element should appear on the map – edit the element 

in the menu boxes on the right).  For another label, add your name, the date, and the data source that you used.  All of the elements 

may be modified once you’ve created them.  To delete any map element, just select it and push delete on your keyboard.  To modify a 

map element, click it and edit the menus on the right-side of the screen.  In the Item Properties menu, you can change the style and 

color of each elements.   
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Part 6.  Saving and Exporting Your Map 

 

Once you have added the map elements, and are satisfied with your map, you should save it.  Click Composer > Save Project.  

Quantum GIS automatically saves maps in .qgis format.  This format stores the arrangement of your map only.  If you send your .qgis 

file to another person, they will not be able to view it, because they will not have the data that you used, only the arrangement of the 

data.  To share your map image, it’s easiest to export it. 

 

To export your map, select Composer  > Export as image…   

 

Choose a name for your map, then in the drop down menu, select to export the map in .JPG format.  This is a file format everyone 

with a computer can easily read; it’s also good for transferring information over the web. 

 

To review, in this tutorial you’ve downloaded and unzipped spatial data (both raster and vector data types).  You’ve also added spatial 

data to a GIS, modified the display of the data, and saved and exported the data display.  Good work!  

 

If you stick with the subsequent tutorials, what you will find is that you will be able to create customized maps and spatial data 

analysis far beyond the scope of existing web applications and software.  You can add your own knowledge, interests and experience 

to the study of the EPA’s Toxic Release Inventory.
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Here is my example: 

 

 

 

 


