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Tutorial 4:  Query and Select Spatial Data 
 
This tutorial will introduce you to the following: 
 

 Identifying Attribute Data Sources (Review) – Toxic Release Inventory (TRI) facilities and NJ County boundaries 

 Joining Attribute Data (Review) – information on lbs. of toxic releases from 1988-2011 

 Using the Clip Tool – narrowing down national data to data for one state – New Jersey 

 Creating New Fields 

 Querying and Selecting Data 

 Generating New Data Sets from Existing Data Sets 

Part 1.  Identifying Attribute Data Sources  
 
This tutorial will work with data that we have used in tutorials: the Toxic Release Inventory data set and the New Jersey 
county boundaries.  (To review, download the facilities listed in the Toxic Release Inventory from TOXMAP and the New Jersey 
county boundaries from the New Jersey Geospaital Information Network.  After you’ve downloaded the files that you need, 
extract, or unzip them.) 
 
You may either open your previous Tutorial 1 file, or you may work from a new blank map.  Either way, you will need to have 
the TOXMAP TRI facilities and New Jersey county boundaries.  In addition to these files, you will need to visit the TOXMAP site 
to also download information about chemical releases from each TRI facility.  The data are available here: 
http://toxmap.nlm.nih.gov/toxmap/download/facilities.zip .  After you have extracted the facilities.zip file, you can add the 
data to ArcMap using the Add Data button, or by clicking File > Add Data.  This particular file is saved as a .txt file, in comma-
separated text format.  You may add this to ArcMap, and it will simply appear as a table.  Before proceeding, you will find it 
easier to work with the .txt file if it is in .dbf format.  To convert the file, open ArcToolbox and select Conversion Tools > To 
dBASE > Table to dBASE.  The input should be facilities.txt and select an output folder location.  Once the dBase is created, add 
it to your map.  The default name is facilities_txt.  Also, to avoid confusion, remove the facilities.txt file from your table of 
contents (right-click and choose Remove).  Save your work before continuing. 
 

 
Part 2.  Joining Attribute Tables (Review) 
 
Last week we joined data from the Department of Health to a NJ counties shapefile.  Today we will join data from TOXMAP 
about TRI releases to the TRI facilities shapefile.  To do so, right-click on facilities_all layer, and select Joins and Relates > Joins 
…  Complete the dialog box as shown on the next page.  FACN, or facility number is the unique identifier that combines two 
different tables of information.  Click OK. 
 
 

http://toxmap.nlm.nih.gov/toxmap/download/shapefile.zip
https://njgin.state.nj.us/oit/gis/download/bounds_nj_shp.zip
http://toxmap.nlm.nih.gov/toxmap/download/facilities.zip
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Joining attribute tables in ArcMap creates a temporary join.  To make the join permanent, right-click on the facilities_all layer, 
and select Data > Export Data.  Save the new file with a name and location that you can remember (I saved my file with the 
name TRI_Facilities).  Also, change the drop down menu to save the file as a shapefile.  Once the export is complete, you will 
be asked if you would like to add the file to the map.  Choose Yes.  Because this replaces the previous data, you may remove 
facilities_all and facilities.txt from your map (right-click the layer > remove). 
 
 
Part 3.  Clip Data Tool 
 
Often when working with large data sets, you will want to narrow down the information that you are analyzing.  One way to do 
this is to use the toolbox.  For example, instead of working with the TRI facilities for the entire US, you may want to work with 
only facilities that are located in New Jersey.  To do this, open ArcToolbox and select Analysis Tools > Extract > Clip.  Fill out 
the dialog box as follows (see image below).  This will clip away all facilities that are not located in New Jersey – like a cookie 
cutter.  Make sure that you change the Output Feature Class to a location that is not the default location, and save it to a folder 
that you can find.  Then, click OK. 
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Already you can begin answering some more complex questions with the analysis that you have done.  For example, how many 
EPA regulated facilities are there in the United States (find the layer that you need, right-click on it in the table of contents, and 
select Open Attribute Table – the total number should be reported on the bottom of the table)?  How many of them are in New 
Jersey?  With that information, you can find out what percentage of all EPA regulated facilities are located in New Jersey.  After 
you compare New Jersey and national totals, you can either remove or uncheck the layer with the national TRI locations. 
 
Part 4.  Creating New Fields, Selecting Data and Analysing Data Using Queries 
 
All previous tutorials have relied on attribute data that have already been created for you, but you can also create your own 
attribute data.  Existing in this particular data set are reports of lbs. of toxic releases for each facility, by year, from 1988-2011.  
But, suppose you would like to find out changes in emissions, over a decade, say from 2000 to 2010, for facilities in New Jersey.  
You can do that.  The following steps will guide you through one way of finding that information.  Then, you will be asked to 
create your own new fields, data selections, and analysis, in the next tutorial. 
 
 Step 1.  Creating New Fields 
 
To create a new field, which will contain information on changes in lbs. of releases from 2000 to 2010, first open the attribute 
table for TRI facilities in New Jersey (right-click on the layer in the table fo contents and select Open Attribute Table, make 
sure that you are using the New Jersey selection, instead of all national data).  In the top-left corner of the table view (shown in 
the image below), click the first button, and select Add Field.  This field will be used to calculate change, so name it something 
like TOT_CH and save it as a float (decimal number), with say 10 precision and scale (example dialog box below).  Then, click 
OK to create the new field.  By default, all records within the new field will be given a value of zero (again, a screenshot is 
shown below).  In the attribute table, right click on the name/column of the new field that you created, and select Field 
Calculator … 
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The Field Calculator uses SQL (structured query language) to generate the values for new attributes.  Double click on existing fields in 

the “Fields” section of the calculator, and they will appear in the box below, which defines the new change field that you created.  

Change is calculated as TOT_2010 – TOT_2000.  This will mean that the new value will be positive if toxic releases have increased, 

and negative, if they have decreased.  Click OK. 

 

 

 
After your new field has been calculated, right-click once again on the name/column of the field in the attribute table.  This 
time select Statistics.  This will give you a statistical summary of the field that you made. 
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That was fairly simple.  From the statistical summary, the mean suggests that the total releases have declined for these toxic 
release facilities.  However, there is another catch to working with this data.  If you carefully examine the tables, the total 
releases for many facilities over different years is reported as -1.  How can this be?  Well, what this really means is that the 
data are missing or not reported.  To make the information that we calculated becomes meaningful, we need to exclude 
records where the information was missing for either 2000 or 2010.  Again, SQL will come in handy. 
 
 Step 2.  Selecting Data Using Queries 
 

To select records, which were not missing for the years 
2000 and 2010, choose Selection from the very top tool 
bar in ArcMap, and pick Select by Attributes.  An SQL box 
will appear.  Here’s how to fill it out:  
 
The layer that we’re selecting from is one with New Jersey 
Toxic Release Sites.  Use the default method, which is to 
create a new selection. 
 
Again, you can double click from the box with the list of 
fields to add them to your SQL box at the bottom.  Select 
the variables in your New Jersey TRI data set where the 
total releases for 2000 are greater than zero AND the total 
releases for 2010 are greater than zero.  Click OK.  Now, 
only records where releases were recorded for 2000 and 
2010 will be selected in your data set. 
 
Selected records in your attribute table, and the points on 
your map, will appear highlighted in light blue.  Tasks that 
you perform when subsets of the data are selected, 
typically only include the selected data. 
 
For example, if you right-click on the field name/column 
for total change again, and select Statistics, the statistical 
summary will now show you information for just the 
selected records.  An example is shown in the screen shot 
on the next page. 



Drew University – Spatial Data Center 
Geographic Information Systems 
Tutorials 

 

 

Drew University – Spatial Data Center 7 

 
 
Interestingly, by looking at only changes in facilities that had releases in both 2000 and 2010, the mean change shows a 
greater decrease than when we mistakenly looked at the data that included missing information. 
 
 Step 3.  Analyzing Selected Data 
 
From the New Jersey total layer, it is possible to make and save a new layer with only the 202 records that had positive 
releases for both 2000 and 2010.  To do this, right-click on the New Jersey TRI layer, and choose Data > Export Data.  The 
default is to export only selected layers, which you want to do.  Save the file with a new name and location that you can 

remember. 
 
Then, click OK.  Go ahead and add this data to the map, and 
remove or uncheck other point layers. 
 
Up to this point, you have conducted some great analysis.  
Now, the hard part, taking the information that you have 
created and conveying it in a map.  Give it your best try!  I 
am looking for the selected points as the only point layer 
and New Jersey boundaries.  I would like to also see you 
change the classification to indicate differences in the 
values of releases for the different facilities (Hint: like the 
NJ county health data, double click the points layer, and go 
to the symbology tab – change to display Quantities > 
Graduated colors for the total change variable).  Add a title 
and legend. 
 
Save your image as a .jpg, and upload it to Moodle.  Good 
work! 
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Here’s my example (Note: this demonstration shows much more information than the tutorial describes, but I wanted to show 
you some interesting possibilities for data display.  As a puzzle, see if you can figure out how I made these maps.).  Below this 
are two other examples from peers. 
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TRI Facilities in New Jersey 
Change in Toxic Release, 2000-2010

TRI_DecadeChange

TOT_CH

-3122000.000000

-3121999.999999 - -405600.000000

-405599.999999 - 69110.000000

69110.000001 - 682800.000000

682800.000001 - 2302000.000000

By Derek Schweighart
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Tutorial 4 – Part 2 – Selective Mapping and Display 
 
This tutorial picks up where Tutorial 4 left off and will introduce you to the following: 
 

 Spatial Joins - Summarizing and Generalizing Point Data 

 Influencing Visual Presentation of Data Using Different Classification Schemes 

 Trying It on Your Own! 

 

Part 1.  Spatial Joins 

In previous work, we have created attribute joins, which join two tables based on a unique identifier, or common field.  Spatial 
joins combine information based on their relative location.  A common use for spatial joins is to summarize information at a 
different scale.  For example, we have data on TRI releases between 2000 and 2010 for point locations in New Jersey.  It might 
be useful to know the total change in emission for each county as a whole.  A spatial join will help us find this information. 

 
To create a spatial join between TRI facilities that 
have changed in the last decade and New Jersey 
counties, right-click on the New Jersey county 
boundaries in the table of contents, and select Joins 
and Relates > Joins. 
 
Instead of the default option, which would be to 
join based on attribute, choose instead to Join data 
from another layer based on spatial location. 
 
The layer to join to counties will be the TRI layer 
that selects data where releases have been greater 
than zero for facilities in 2000 and 2010. 
 
For generalizing the information, choose to sum 
the data.  This way for each field the value will now 
be the total for all records contained in each 
county.  For example, the total change column will 
be the summation of all change for all the facilities 
in each county. 
 
Save the information to a location and a name that 
you can remember, and make sure it’s saved as a 
shapefile.  Then, click OK. 
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Part 2.  Using Different Classification Schemes 
 
Now you can study the changes in toxic releases in New Jersey for each county.  To do this, double click on the new spatial join 
layer that you created.  Mine was named TRI_NJCounty.  As in previous tutorials, click the Symbology tab, and show Quantities 
> Graduated Colors.  The value should be the sum of total change.  Instead of using the default Jenks Natural Breaks, click the 
Classify button, and change the drop down menu for method to try a different scheme.  Both the scheme and color can make a 
big difference on how your audience interprets your map. 
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One of the most wonderful things about map analysis is that it can really expand on simple statistical summaries.  Way above, 
on page 7 of Tutorial 4, the statistical summary showed that, on average, toxic releases have declined in the state of New 
Jersey.  This is true.  However, by mapping this information, it becomes obvious that emissions didn’t decline uniformly.  
Rather, there appears to be almost a north-south trend, where northern counties experienced a decline and southern counties 
may have even experienced an increase.  Another map might take into account total emissions, to show where the highest 
releases in the state are overall. 
 
Part 3.  Create Your Own Analysis! 
 
The last step is to try out some of these techniques for yourself.  Perhaps you would like to compare different years: 2010 and 
2011, or 2011 to 1988.  Perhaps you would like to look at a different state.  In your analysis, I would like to see one data frame 
(map) with points, and one data frame (map) with counties, where the counties are illustrated using a thematic or choropleth 
map (like the one above).  Add a title and at least one legend.  Have fun!  When you’re done, save your map as a .jpg, and share 
it with others. 


